2jz-vvti sync but no spark, Infinity, V2, IGN1A | AEM
3 posts / 0 new
Last post
captainjdog
Offline
Last seen: 3 months 2 weeks ago
Joined: 11/04/2019 - 14:37
2jz-vvti sync but no spark, Infinity, V2, IGN1A

Hi,
I'm here for a last resort as I am out of ideas...

93 Toyota Supra N/A , Aristo 2jz-gte vvti swap.
Custom harness purchased, The important pins verified
Aem V2 2.02 or AEM Infinity 506 (Currently troubleshooting with infinity 506)
IGN1A Coils 

Verified every Coil Plug connector has:

    Pin A - Verified 57B (Ignitor 1) 
    Pin B - Verified 65B (Sensor Ground ECU)
    Pin C - Verified Grounded to Head
    Pin D - Grounds to negative Battery (Unable to verify how, without tearing the harness apart, but currently 0 - ohms out to negative battery)
    Pin E - Verified 12V through ignition controlled 30amp relay

The engine will turn over and receive Stat Sync ON in AEM Tuner but I still have no spark. 

I thought perhaps something was wrong with the AEM V2 coil driver so, I tried swapping to an AEM Infinity 506 and receive SYNC 1 in Infinity tuner, but again no spark.  (Both ECU's work in a second car with stock-ish 2jz)

- All other sensors are reading correctly, IAT, TPS, Coolant, ect ect , So I assume the sensor ground is working correctly
- Verified all engine safety is off in case a safety event was being triggered.

I'm in a puzzled mindset and not sure how to proceed, I think I’ve narrowed it down to the following:
A - The ECU is SYNC1 but not triggering the coils for some reason.   Does SYNC-1 guarantee the coils should be firing?  I'm not sure which log to capture the verify output coil fire event, nothing I've tried seems to capture it, or either the event is not happening.
B - Something in the coil wiring is incorrect.
or
C - The ever glooming Crank / Cam sensor. (I would think the SYNC -1 status eliminates this as a possibility?  Everything appears happy, but I could be wrong) 

       I use the VVTI 36-2 wizard setup, but I have to lower the CAM NC to 5 in order for the ECU to detect the cam to trigger SYNC-1. (Logs look good for cam & crank duration, Crank angle is consistently 720 looping)
       I also use the dwell configuration to select AEM IGN1A smart coils. 

   
Things I would like to test:
1. I keep reading about the Output Diagnostics firmware that I can use to manually trigger the coils. If the coils fire or don't fire, that would narrow things down. 
Unfortunately, I can't find where to download the firmware package from AEM. (Unless it was included in the Infinity Package I already downloaded. I'll go check ... writing down your thoughts sometimes trigger new ideas.) 
 
2. Pending results from Test 1 and the Sync1 question. If the coils fire, I will oscilloscope the cam and crank sensors to make sure they look correct.
3. If coils don't fire, I'll repin the coil connector Pin D and jumper it directly to the negative battery terminal.

Am I overlooking anything obvious? or not obvious?

I can upload any logs, just let me know which events you want captured. 

Thanks for any assistance. 

AEM_NS
Offline
Last seen: 16 hours 40 min ago
Joined: 06/06/2014 - 09:31
Logs from both ECU's of the

Logs from both ECU's of the engine cranking would be helpful to see. For the Series 2, take a log of the Adv Pickups tab. In that tab also add a channel display and in the tree menu, select Ignition>Advanced Ignition>Coil Dwell Time>Channels - Coil Dwell. These channels will tell us if the coil outputs are being fired or not.

captainjdog
Offline
Last seen: 3 months 2 weeks ago
Joined: 11/04/2019 - 14:37
SOLVED

SOLVED
Thanks for the response AEM_NS.
After downloading and loading the Output Diagnostics package, I discovered that after triggering the coil I still had no spark. So I traced every wire from the coil, Verified Coil Pin D did indeed go to the battery ground. 

But I was incorrect in my previous Pin B verification, The Pin B coil trigger ground was going to 28B (Still a Sensor Ground). I removed the coil trigger ground from pin 28B and jumped it to chassis ground for a test, and Viola I had spark. For a second test I jumped the coil trigger ground to 65B (Sensor Ground) and I had spark, so I spliced it in with pin 65B
I'm not sure what the differences between sensor grounds on pin 28B and pin 65B are, but pin 28B didn't work for the coils. /shrug

With renewed enthusiasm, I verified timing and it fired right up! Thanks for designing the Output Diagnostics package.
I switched to the V2 and again it fired right up. 

V/R,