30-2013 Temp Sensor with CD-7 question | AEM
4 posts / 0 new
Last post
turbogate
Offline
Last seen: 20 hours 44 min ago
Joined: 08/09/2015 - 07:40
30-2013 Temp Sensor with CD-7 question

I'm using the 30-2013 temp sensor as an oil temp sensor and followed this thread below to get me going, but i'm not getting the expected results. I have a question.

Car is running the Supra 6100 box, i'm using ADCR14 as my input to the ECU with Spare Temp 1.  AEM Tuner seems to be reading the temp correctly.

Which CAN message do I pass to the Dash? ADCR14? Spare Temp 1, Spare Temp 1 Volts?  ADCR14 uses 2 bytes vs. the others.  I'm not getting lucky with Spare Temp 1 so far.

Any guidance is appreciated.

Reference thread:

https://www.aemelectronics.com/forum/aem-sensor-function-operations

Thanks

 

AEM_NS
Offline
Last seen: 10 hours 58 min ago
Joined: 06/06/2014 - 09:31
How did you setup the CAN rx

How did you setup the CAN rx for Spare Temp?  In the CAN Telemetry window in AEMTuner, if you add in Spare Temp somewhere and then click on Show Info, the Telemetry Info says that Spare Temp is sent out the same way as Coolant and Air Temp.  Check the CAN rx for Coolant/Air Temp in Dash Design and you'll see they're setup as a Signed Integer.  This is called a Two's Complement and it splits an 8 bit value (0-255) in half so it get split as -128/+127.  If you don't setup the rx side for Sign Integer, you're going to get a really funky value.  I'd try matching the rx config to be the same as Coolant/Air Temp with the same scalar/offset and see if that gets you any where.  

turbogate
Offline
Last seen: 20 hours 44 min ago
Joined: 08/09/2015 - 07:40
Spare Temp 1 in the CAN

Spare Temp 1 in the CAN Telemetry is set-up the same as Coolant and AIT (see below).  I went back to the basics following your information and I think i'm good to go now.  Temperature on Dash now matches AEM tuner.  I should not have followed that thread mentioned as it looks like it's not applicable to my configuration.  No need for a function it seems.

Thanks for the help!  I'll drive around to confirm i'm good to go.

Name: Spare Temp 1
Unit:    C
Scalar: 1
Offset: 0
Min: -128
Max: 127
Signed: Yes

AEM_NS
Offline
Last seen: 10 hours 58 min ago
Joined: 06/06/2014 - 09:31
Glad you got it working now. 

Glad you got it working now.  That other thread would be applicable if you were sending over a raw voltage signal but in this case you're sending over a scaled temperature.  You just had to match the rx to jive with the tx configuration.