3SGTE ignition misfire high RPM, Dwell time | AEM
9 posts / 0 new
Last post
3S-GTE
Offline
Last seen: 5 years 6 months ago
Joined: 10/22/2014 - 08:30
3SGTE ignition misfire high RPM, Dwell time

I am having a ignition misfire at 5400-6200 rpm that is limiting performance in a bad way. The problem was discovered on the dyno, and since I have replaced all igniton components including; Dist. cap and rotor, plug leads (Magnecore), coil (MSD blaster II), MSD digital ignition controller, plugs are a colder range with a gap at around .020, also replaced the alternator. The problem has improved a bit but is still present. I am wondering if I need to change the coil in coil wizard since it is still set as mr2 turbo, also am wondering about adjusting dwell time. Has anyone experienced similar problems with this engine at this rpm range, or have any advice. Thanks in advance!

If it helps garett turbo is at 15psi and fuel system is 1200cc injectors at 48% duty cycle making around 310awhp on a mustang awd dyno. 

 

AEM_PT
Offline
Last seen: 2 months 1 week ago
Joined: 05/22/2014 - 08:13
Please post cal and data log.

Please post cal and data log. The issue could be a plethora of things.

3S-GTE
Offline
Last seen: 5 years 6 months ago
Joined: 10/22/2014 - 08:30
It doesn't seem like I can

It doesn't seem like I can post attachments? 

bigrobintx
Offline
Last seen: 4 years 2 months ago
Joined: 10/27/2014 - 07:51
I had the same problem on my

I had the same problem on my 1993 Toyota MR2. On the 1993, the Toyota igniter handles the dwell for the stock coil. The stock ECU simply provides the "fire" signal. Therefore you want dwell on the AEM to be fixed and as low as possible whil still being recognized by the igniter. From my understanding the 1991 and 1992 models had to have dwell provided by the ECU. AEM overlooked this fact on the start-up calibration file for the 1993 model year MR2s. Another issue I had was garbage in the signal from my distributor which the AEM is less forgiving than the OEM ECU is. I would do a datalog of the crank and cam signals and see what it looks like, or better yet, pop them on an oscilloscope because the datalog from the AEM isn't really fine grained enough to tell for certain. I ended up running new shielded wire from dizzy to ECU and that, in combination with the fixed low dwell time solved my issues, I rev past 7 k now no problems.

3S-GTE
Offline
Last seen: 5 years 6 months ago
Joined: 10/22/2014 - 08:30
How low of dwell time? I have

How low of dwell time? I have a 1990. I drove it yesterday and did a few WOT pulls and have logged them with no misfire. Then I drove it again, and mild misfire. The dewll factor is set at 20 and the coil is still set to mr2 turbo in coil wizard, the only msd option is ss coil. The problem has gotten a bit better but seems to still be present. I want to post the log and the cal but there is no option and I don't know what dropbox link means as AEM_PT mentioned. 

AEM_PT
Offline
Last seen: 2 months 1 week ago
Joined: 05/22/2014 - 08:13
You need to host the file

You need to host the file somewhere like Google drive or as mentioned Dropbox. Once you have the files hosted you can post a link on here where fellow members can access the file and assist.

3S-GTE
Offline
Last seen: 5 years 6 months ago
Joined: 10/22/2014 - 08:30
Thank you, I swear I'm not an

Thank you, I swear I'm not an idiot...i just don't spent a lot of time on new technology...which is strange because im under thirty, anyways, here are the links to the log without any misfire and with misfire, also my calibration file. I want to see if I can correct this otherwise, Is my v1 compatable with the 4 channel coil driver and the Pencil coils? or do I have to change a lot?

Thanks for the help

no misfire; https://drive.google.com/file/d/0BwzlaV0LJXXBUHNWLUFoQW9SMzQ/view?usp=sh...

misfire logs; https://drive.google.com/file/d/0BwzlaV0LJXXBelAtQ05CQXMxeXM/view?usp=sh...  https://drive.google.com/file/d/0BwzlaV0LJXXBSXM4VHoyUXRqdXc/view?usp=sh...

Cal. https://drive.google.com/file/d/0BwzlaV0LJXXBVmgxekhZTXhMdlk/view?usp=sh...

3S-GTE
Offline
Last seen: 5 years 6 months ago
Joined: 10/22/2014 - 08:30
Any thoughts, anyone? 

Any thoughts, anyone? 

spoon_ek9
Offline
Last seen: 3 years 2 months ago
Joined: 11/23/2014 - 20:59
with an external ignition

with an external ignition controller, your coil dwell setting for sure be wrong.

now your log look like some problem on your fuel supply IF your tune is exactly the same between the misfire and non misfire one. coz O2 is different before the misfire happened.

 

GK System - Efi and data acq specialist