Aem 30-1100 EGT #3 Input Not Working? | AEM
5 posts / 0 new
Last post
WarIsHate
Offline
Last seen: 1 day 19 hours ago
Joined: 05/07/2020 - 05:12
Aem 30-1100 EGT #3 Input Not Working?

Hi Aem Family,

  I want to use egt sensor input #3 for a 0-to-5 volt signal from a fuel pressure sensor, but it’s showing no signal in AemPower software. I checked all wiring and it’s good. The first 2 egt sensor inputs work perfect, but why is egt #3 not showing any signal?

EGT #1: Aem rtd-type egt sensor (wired with sensor ground wire as Input and 2nd sensor wire is connected to Aem Reference 5 volt wire)

EGT #2: ProSport Oil Pressure Sensor (12v power, battery ground, 0-to-5 volt output signal)

EGT #3: ProSport Fuel Pressure Sensor(12v power, battery ground, 0-to-5 volt output signal)

AEM_NS
Offline
Last seen: 1 hour 11 min ago
Joined: 06/06/2014 - 09:31
What does showing no signal

What does showing no signal mean? The channel shows a blank? EGT 3 is ADCR15 - what's its value?

WarIsHate
Offline
Last seen: 1 day 19 hours ago
Joined: 05/07/2020 - 05:12
Thanks for replying Aem_NS .

Thanks for replying Aem_NS smiley.  Both Egt #3 and ADR15 show 0.02 volts and in the parameters menu and never change regardless of pressure differences.  How likely is it for a new pressure sensor not to work?

 

AEM_NS
Offline
Last seen: 1 hour 11 min ago
Joined: 06/06/2014 - 09:31
Disconnect the sensor and

Disconnect the sensor and have that input go open circuit. The voltage should go to 5v - does it? If it does, then something about the sensor wiring is pulling the voltage down when it's connected. Perhaps you wired the sensor incorrectly. If ADR15 doesn't go to 5v when open circuit, then something is pulling it down internally. If I were you, I'd just take the board out of the enclosure and trace back the circuit from the ECU header pin and see if you can spot anything wrong.

WarIsHate
Offline
Last seen: 1 day 19 hours ago
Joined: 05/07/2020 - 05:12
After disconnecting both

After disconnecting both sensors, they're showing as 0.2 volts.  Strange?