AEM Meth Failsafe Acting Weird | AEM
11 posts / 0 new
Last post
Alan M.
Offline
Last seen: 6 days 4 min ago
Joined: 04/23/2020 - 21:07
AEM Meth Failsafe Acting Weird

Greetings,

Just got my car tuned with the new aem meth kit I installed. Everything seems to be working fine, however when I opened the aem meth failsafe software to adjust my upper and lower limits I noticed that my meth injection is all over the place. Today was my second day with trying to adjust the limits doing multiple pulls and now the gauge needle doesn't even move past 300cc when I have a 1,000cc nozzle, but on the software it is registering over 1,000cc at some points and it is very unstable to I can't even get my upper and lower limits properly set.

 

Here is an image of the injection graph.

meth failsafe.pdf

Seems to also be injecting way over 1,000cc at some points. 

AEM_NS
Offline
Last seen: 36 min 50 sec ago
Joined: 06/06/2014 - 09:31
Give the info under Failsafe

Give the info under Failsafe Configuration another read: https://www.aemelectronics.com/sites/default/files/aem_product_instructi...

Alan M.
Offline
Last seen: 6 days 4 min ago
Joined: 04/23/2020 - 21:07
Ok I checked everything and

Thanks!

Alan M.
Offline
Last seen: 6 days 4 min ago
Joined: 04/23/2020 - 21:07
Sorry to bother again,

Sorry to bother again, however my failsafe is still acting weird. Sometimes it reads the flow then other times it doesn't. Sometimes it even just stays stuck at 300cc or even stuck over 1,000cc on the gauge and I know it is not flowing cause I can see through the software that it is not flowing. Any reasons why the failsafe could be acting so inconsistent? Everything is installed properely and I have read over the configuration section multiple times. Do I have to connect the brown cable to a car ground?

AEM_NS
Offline
Last seen: 36 min 50 sec ago
Joined: 06/06/2014 - 09:31
Perhaps gauge needle driver

Perhaps gauge needle driver has a mechanical problem. You'll need to contact Tech Support directly for assistance: 1-800-423-0046 gen.tech@aempower.com

Alan M.
Offline
Last seen: 6 days 4 min ago
Joined: 04/23/2020 - 21:07
I have called and sent an

I have called and sent an email 5 days ago and still getting no answer. What should I do?

AEM_NS
Offline
Last seen: 36 min 50 sec ago
Joined: 06/06/2014 - 09:31
What address did you email?

Try calling again. Did you actually get through to someone or no?

Also, did you change out the face plate?  If so, perhaps you re-inserted the needle too far onto the shaft and it's rubbing against the face.

Alan M.
Offline
Last seen: 6 days 4 min ago
Joined: 04/23/2020 - 21:07
I called and no one answered.

I called and no one answered. tripled checked the phone number and nothing, will try again. No I did not change the face plate. Kept the black one that it came with. 

AEM_NS
Offline
Last seen: 36 min 50 sec ago
Joined: 06/06/2014 - 09:31
Try calling 310-484-2322.

Try calling 310-484-2322.

Alan M.
Offline
Last seen: 6 days 4 min ago
Joined: 04/23/2020 - 21:07
Sorry don't mean to bother

Sorry don't mean to bother but for some reason the phone lines are not working. Is their any way I could get a response from the email I sent over a week ago? Thanks

AEM_NS
Offline
Last seen: 36 min 50 sec ago
Joined: 06/06/2014 - 09:31
If they had received your

If they had received your email, they would have replied. Message me your email address and I'll have them email you. Or even your phone number.