BMW e30 M30 3,4 Turbo AEM Infinity 506 not running | AEM
5 posts / 0 new
Last post
diki
Offline
Last seen: 3 years 2 weeks ago
Joined: 08/18/2015 - 13:28
BMW e30 M30 3,4 Turbo AEM Infinity 506 not running

Hello my friends,

i have a bigger issue here.

I got the car 3 Times running. But now it does not run anymore.

Every Running test was extremely difficult....

Before we go forward: Here is my base settings:

Put in Data on Wizzard:

______________________Basic Setup_________________________

___Engine___
Displacement: 3.40
Cylinders: 6
Engine Cycle Type: 4 stroke
Ignition Type: Sequential (Coil on Plug)
Firing Oder: 1-5-3-6-2-4
Airflow Calculation Method VE
Main Spark Map Load Axis Selection : Map (kpa)
VE Table Load Axis Selection: Map (kpa)

___Tuning Preferences___
 No Usage

___Cam/Crank___
Universal 60-2 Mag Crank 1 Hall Cam
Crank Noise Cancellation 10
Cam 1 Noise Cancellation 10

I Use a Fiat Uno Turbo Crank Sensor (It fits on my Mounting)
I use a universal Cam Sensor at the place of my distributor.
Sync state is good, and there is no Crank or Cam Syn Error

___Injector Setup___
Primary Fuel Pressure Regulator Reference: Manifold Vacuum Reference
Primary Injector Flow Wizard selection: Siemens Deka 60lb 12 Ohms
Primary Injector Duty Limit: 95%
Number of Injectors 6
Has Secondary Injectors: disabled
Primary Fuel Type: Gasoline

___Basic Sensors___
Air Intake Temperature : I calibrated with the VW Map Sensor, which has also a Temp Sensor on it Now it shows 9°
Volkswagen MK4 (They are almost all the same) (shows reasonable values)
Coolant Temp Sensor Setup: blue ntc from bmw/Bosch (shows reasonable values)
Map Sensor: I thought i bought a 300kpA Sensor (unfortunately there is no Number on it), but when calibrating i noticed:
if i make 0,4V 20kpA and 4,65V 300kpA i get on ambient conditions 115,2 kpA.
That cannot be. when i use 0,4V 20kpA and 4,65V 250kpA i get reasonable Value of 98kpA.
I have also a Manual Manifold Pressure Measurement, to get sure, when it runs
Fuel Pressure:
Static Fuel Pressure 4.5 bar (g)
Calculate Fuel Pressure from Sensor: disabled
Fuel Pressure Smoothing: 60%
Fuel Pressure Sensor Failsafe on: Enabled
Fuel Pressure Sensor Failsafe: 0,82737 bar (g)

Note
I have made a selfmade measurement system after i measured manually the fuel pressure 4,5bar at ambient conditions
After measuring the system I mounted a 0-10 bar Sensor (3-160Ohms) with additional resistance of 220Ohms wiring and made the calibration on manual.
0 bar is 0,14V
10 bar is 2.5V
what us wondering for me:
when putting in the values in bar, aem infinity shows in the Table "Injector" an Injector Pressure of 65.3 [bar (g)]also Fuel Pressure of 65.8 [bar (g)]
when switching to psi the static Fuel Pressure goes to 65.3 psi(g) and the Injector Pressure to 65.8 psi(g) It seems i found a bug in the software :)
I run in psi.

Oil-Pressure Sensor: Oil Pressure Sensor Installed disabled
Oil Pressure Smoothing 50% (i think thats not interesting)
Oil Pressure Failsafe On disabled
Oil Pressure Failsafe 0.0 psi (g) (Also not interesting)

Throttle Position Sensor
TPS Cal Min -2%
TPS Cal Max 102 %
TPS Min Volts 0.14 V
TPS Max Volts 3.46 V
TPS Filter Level: 80
Throttle is unfortunately a 100mm Throttle. I think its to big, but i mounted it. Sensor is from VW Passat.

___DBW-Tuning___
Drive-by-Wire 1 User Enable: Disabled

___Set Throttle Range___
Live TPS Volts : 0.24 (No Foot on the Pedal)
TPS Min Volts: 0.14
TPS Max Volts: 3.46

___Ignition Sync___
Trigger Offset 263 btdc

I used a timing light and found out, that 263 btdc is the right Position.
Pickup Sensor Delay: 100us (default Value)
 
_________________Advanced Setup________________

___Accel and Decel Fuel___
All Default

___Advanced Trims___
All Default

___Boost Control___
All Default (I Mounted a Audi Boost Controlling Valve, but for the beginning i directly Mounted the Turbocharger Output (Boost) to the Wastegate)
Boost Output Enable: Enabled
Boost Feedback Enable: Enabled

___Engine Protection___
Enable MIL Output: Disabled
Max Boost Limit: 18.13 psi
Overboost Allowed: 14.5 psi
Throttle Position Reset: 30%
Oil Pressure Protection Enable: Disabled
Lambda 1 Protection Enable: Disabled

___Idle___
Idle On Below TPS: 5%
Idle on Below RPM 2000
Idle Feedback Min: -25%
Idle Feedback Max: 25%
Advanced Setup is let Default

___Input Function Assignments___
Default

___Knock Setup___
Default (There are Mounted 2 Knock Sensors Bosch to the eng8ne and the ecu, but for the start Knock is disabled)

___Lambda Control___
Uego 1 Sensor Installed: Enabled
Lambda Feedback Enable: Disabled (???right)
Lambda Feedback Rich Limit: 20%
Lambda Feedback Lean Limit: -20%

Lambda Activation Criteria
Lambda Feedback Min Speed: 800rpm
Lambda Feedback Max Speed: 10000rpm
Lambda Feedback Min Load -13.77880 psi
Lambda Feedback Max Load 87.024 psi
Advanced Setup : Default

___Launch Antilag___
Launch Retard Enable: Disabled
All other Points Default Off

___Launch Timer___
Launch Timer Enable: Disabled (Default was Enabled)

___Nitorus N2O___
Default

___Main Rev Limiter___
Rev Limit: Fuel Cut 4000rpm
Rev Limit: Spark Cut 5000rpm
Rev Limit Ignition Retard: 4900rpm
Rev Limit Ignition Retard Amount: 10 degrees BTDC
Advanced Setup
Fuel Cut Start Window 200rpm
Spark Cut Start Window 200rpm
Rest is Default

___Rev Limit 2 Step___
Default (Disabled)

___Rev Limit 3 Step___
Default (Disabled)

___Shift Cut___
Default

___Traction Control___
Default (Disabled)

___USB Logging___
Default (I logged only manual)

___VVC___
Default (Disabled)

___Diagnostics___
(I let everything Default, but is neverything right?
Battery Filter 70%
Crank Maximum : 400rpm
Crank Minimum : 25rpm
CrankEdge RPM Smoothing Filter : 95%
ECU Shutdown Time: 5000ms
Engine Speed Filter Level 96.0%
Fuel Cut bFeedback Window: 200rpm
Ignition Map Filter Level: 30%
Spark Cut Control Window: 200rpm

VR1_PwmDuty xaxis: Enginespeed (rpm)

Cam/Crank Settings all Default

____________________________________________________________
This was all to the normal Wizzard.
I think there is almost one thing i can Setup more before starting and thats the Dwell Time of the Coils

I Use AEM Dumb Coils with external Igniter (2x3 Channel from Audi S6)
At 200rpm i got
16 V - 3.0ms
14V- 3.0ms
12V 3.0ms
10V-6.0ms
8V- 6.0ms

From 2000 to 8000rpm its about 2

I don`t know if this is good, but on the coils is written:
Max Dwell Time 9ms
Duty 40%
So i can raise it

Spark Plugs are W4DP0 Platinum-Iridium
0241250502

Unfortunately the car does not want to make cold start ...but i don`t know why.

There is no start anymore :(

Diagnostics is nothing red....Sync State jumps to 1 while cranking, but unfortunately..no firing...only some little times i get one or 2 firings.

i tried with brake cleaner..but its very bad. i don`t know what happened.
It got the car started 3 times....but it feels, that it only works, when its warm in the garage. When engine was warm, it started everytime i crank.

I should also say: I Use a 300 degrees Camshaft with bigger Valve lift.
The camshaft timing i measured with a good friend who adjusts lots of race cars..but he is only expert in carburating cars :( He can`t help me with the ecu
While cranking there is almost absolutely no map changing to underpressure. Not on the ecu sensor, also not on the mounted boost gauge.
When the car is running....its wanting rpm....
When it ran, Idle was going at about 1700rpm...lower rpm was not good.

But now it does not run any more. :(

Here are some screenshots:
1. Diagnostics Table

http://img5.fotos-hochladen.net/uploads/screenshot149yrf5h1vgju.png

2. Ignition Trims Table

http://img5.fotos-hochladen.net/uploads/screenshot150qr5za13nwx.png

3. Start Table

http://img5.fotos-hochladen.net/uploads/screenshot151kunsmdczg0.png

4. Idle Table

http://www.fotos-hochladen.net/uploads/screenshot15263frnjulem.png

I have also some logs, if this would help?

Next steps from my side would be:
Cleaning Spark Plugs (I have do Demount the Downpipe with Lambdasensor) and the Wastegate for this....Its a hell of a Job :( I don`t know if the plugs are clean or in which condition...The car ran very rich, when it ran last time (Lambda 0,75)
Looking at the Valve clearance on the camshaft...And then one more time Cam timing.

Also i will try to put the car behind another car and try to start it while engine is running at higher rpm?

What would you specialists say to my Problem?

Can anybody see something wrong in my Points?

Greetz from Germany

 

diki

 

 

AEM_NS
Offline
Last seen: 2 hours 17 min ago
Joined: 06/06/2014 - 09:31
I'm sure you put considerable

I'm sure you put considerable time into your post but please see our Infinity troubleshooting Posting Standards HERE.  Instead of describing your settings, it's much easier for us to just have a copy of your session and some logs that show the problem you're having.

diki
Offline
Last seen: 3 years 2 weeks ago
Joined: 08/18/2015 - 13:28
okidoki, but how can i send

okidoki, but how can i send you my session and log files?

 

 

 

AEM_NS
Offline
Last seen: 2 hours 17 min ago
Joined: 06/06/2014 - 09:31
Host them somewhere and then

Host them somewhere and then provide a link to download them.

diki
Offline
Last seen: 3 years 2 weeks ago
Joined: 08/18/2015 - 13:28
hi there,

hi there,

i found the problem.

the ar ran so rich, that the plugs were black. and because of being so rich, the plugs get wet immediately, when i crank. after cleaning plugs. car starts. but after 3 times starting same issue. so i have to get the car much less fuel.

but when putting lean i had a lot of misfire and the car does not get lots leaner..i was surprized..i have to find out more.

today i will unmount downpipe to clean plugs...thats such a hard job everytime....guys..never use 2 valve engines for turbos.....if i had 4 valve...plug changing would be so easy....

 

greetz

 

diki