10 posts / 0 new
Last post
neilsandviper
Offline
Last seen: 1 month 3 weeks ago
Joined: 01/29/2020 - 12:01
cold air intake with maf

can i use a cold air intake with maf port instead of using a map and a air sensor  with the ems -4 on my sand rail witch has a toyota 1.8 1zz engine out of a 2003 matrix 

Avry
Avry's picture
Offline
Last seen: 1 day 15 hours ago
Joined: 04/05/2020 - 14:51
neilsandviper wrote:

neilsandviper wrote:

As far as i know, the Ems-4 does not support MAF, but i think that you would be able to run the fuel map based on the TPS.
I send you a PM as well

AEM_NS
Offline
Last seen: 7 hours 53 min ago
Joined: 06/06/2014 - 09:31
The EMS-4 does actually

The EMS-4 does actually support MAF fueling.  My best advice is to look at the 6101 SC300 MAF.01V24 base cal since it has all the correct settings for MAF fueling but honestly, what you might be saving by using a MAF that's already there vs adding on a MAP & IAT sensor, you'll lose in cal setup and calibration time.  I suggest going Speed Density with a MAP & IAT sensor.   

Avry
Avry's picture
Offline
Last seen: 1 day 15 hours ago
Joined: 04/05/2020 - 14:51
AemTuner softwere says that

AemTuner softwere says that MAF is tulically set to Maf volts, but as the EMS-4 doesn't have a dedicated MAF input, to set the MAF for EMS-4 on the MAF Analog Input dropdown menu it should be choosed as MAF as Load or GPIO Volts?
But then, when I go to Configure Outputs, it's not showing up. Should I choose in there User#1 - User#1 PW Analog Input: GPIO2 Volts? Thank you!

AEM_NS
Offline
Last seen: 7 hours 53 min ago
Joined: 06/06/2014 - 09:31
Why would an input assignment

Why would an input assignment show up in Configure Outputs which is for output functions?

Avry
Avry's picture
Offline
Last seen: 1 day 15 hours ago
Joined: 04/05/2020 - 14:51
Sorry, newbie questions :) It

Sorry, newbie questions :) It was the 2step that got me thinking it should show up in both sections... Then I will assign the MAF input as GPIO Volts. As for the 2Step I should assign it only as an Output to Gpio Gnd=On and leave blank the input?

p.s. Neilsandviper, sorry for asking questions on your thread!

AEM_NS
Offline
Last seen: 7 hours 53 min ago
Joined: 06/06/2014 - 09:31
I think maybe concentrate on

I think maybe concentrate on getting the engine to run with MAF and worry about things like 2 Step config later.

Avry
Avry's picture
Offline
Last seen: 1 day 15 hours ago
Joined: 04/05/2020 - 14:51
I will do that definitly, 2

I will do that definitly, 2 Step is my least concearn anyway. Is just that tomorrow I will finish the harness I've made and I want to be sure that the connections will be assigned where they have to be. So Maf input set to Gpio Volts, then?

AEM_NS
Offline
Last seen: 7 hours 53 min ago
Joined: 06/06/2014 - 09:31
Yes, pick an available GPIO.

Yes, pick an available GPIO. I can see why the outputs thing is confusing because 2 Step is in there but there's no output for 2 Step. It shouldn't be listed in outputs just like Anti Lag and Switch Retard - those are all inputs. For 2 Step, you configure it in the Limiters tab. Just pick an available GPIO for the drop down list for 2Step Input. And always make sure that ANY switch input into the EMS-4 is a ground switch.

Avry
Avry's picture
Offline
Last seen: 1 day 15 hours ago
Joined: 04/05/2020 - 14:51
I will, thank you alot!

I will, thank you alot!