Controller not coming on accuratley to MAF frequency | AEM
4 posts / 0 new
Last post
vortech
Offline
Last seen: 1 month 2 weeks ago
Joined: 09/28/2015 - 09:19
Controller not coming on accuratley to MAF frequency

I have the AEM controller dip switches set to read MAF frquency at 2K and 14K HZ. So 6K would be 40% on the dial and 10K would be 80%. Hower at those settings the pump doesn't even come on. I had to set the MAF to 15K for to come on at 7200 HZ. I'm loggin my meth pump with aem  pressure sensor so I know its accurate. Any idea what I could be doing wring

AEM_NS
Offline
Last seen: 29 min 32 sec ago
Joined: 06/06/2014 - 09:31
What is status LED doing when

What is status LED doing when you see no pressure?

vortech
Offline
Last seen: 1 month 2 weeks ago
Joined: 09/28/2015 - 09:19
It is just dimly lit then

It is just dimly lit then comes on when it sprays. It does flash 5 times on start up. 

AEM_NS
Offline
Last seen: 29 min 32 sec ago
Joined: 06/06/2014 - 09:31
Sorry I misunderstood your

Sorry I misunderstood your original post. I was under the impression that it had been coming on as expected but then wasn't. You're saying it doesn't come on when you're expecting it to based on the settings you dialed in. To that I'd say that it probably matters a whole lot less that the system comes on based on a certain dial position vs coming on at a certain engine load or manifold pressure. If the system is consistently coming on when it's supposed to and it's at the right time to when the engine needs it, does the position of the dial really matter?