ems-4 2G Eclipse, won't start coil2 stuck on | AEM
3 posts / 0 new
Last post
emiller81
Offline
Last seen: 3 months 3 weeks ago
Joined: 04/19/2020 - 11:30
ems-4 2G Eclipse, won't start coil2 stuck on

I have a '97 Eclipse GSX. I have the 7 bolt 4g63. I have installed/wired the ems-4 into my vehicle about 10 yrs ago. I worked on getting to the point were it would run and now the vehicle doesn't even want to back fire. I think the file got corrupted or something because it won't even start now. I have started a brand new file and did all the wizards and it still won't fire. (it will run for a few sec if I put ether in the throttle body, but won't stay running)

I logged the startup and noticed that the injectors and igntion coils aren't firing when they should be. I am running wasted spark with a M&W igntion setup with COP 300m coil setup. 

I thought there was something wrong with the ECU as coil 2 output shows on all the time before stat sync even comes on. I don't even have coil 2 on and I'm using the wire out 1, 1b, 3, 3b for my setup so I'm not sure why coil 2 would be on all the time. I sent the ecu in to have inspected by AEM they said it tested out fine. I tried another ems-4 and same results happend with coil 2 being stuck one. I've double checked my wiring mulitiple of times. Coil2 ouput is not connected to anything.

I am running stock crank and cam sensors. AEM mentioned that the resolution can't handle the aem ems-4 but I've had it running before and doesn't explain why coil 2 shows on all the time even though its shut off in the programming. I could swith over to the 12-1 setup if this will resolve the issue but I'm not sure it will.

Here is a quick run down of the setup

(2g)7 bolt 4g63
Stock crank and cam sensors
300m cop seutp with M&W pro - batch firing
FIC injectors 1650 high impedience injectors

eclipse base updated with wizards.AEM20.01V24.cal

 

2020-02-20 1525 PC Log.daq

I'm running AEM Tuner version 3.2 since I'm running windows 10.
I have a password saved on file,

If someone could look at the log and cal file to see if you see errors or any suggetions. I'm completely lost and have been working with AEM for months on this.
 

 

emiller81
Offline
Last seen: 3 months 3 weeks ago
Joined: 04/19/2020 - 11:30
I went and found a thread

I went and found a thread about turning on crank alt fire. So I turned it on and logged it. Looks much better but it didn't even kick or start. But it looks like progress. 

Log file attached. Same cal file as before just changed the one setting of Crank Alt Fire.2020-04-19 2024 PC Log.daq

AEM_NS
Offline
Last seen: 52 min 51 sec ago
Joined: 06/06/2014 - 09:31
You have a couple options.

You have a couple options. First, there's a 1G DSM base cal in this thread: https://www.aemelectronics.com/forum/ems-4-diyfaq-look-here-first  I'm not a DSM guy so I'm not sure what the difference is between 1G & 2G crank/cam stuff, but if you make your crank/cam profile match a 1G, the 1G base cal will get you going. Second option - ditch the stupid stock 2 tooth crank trigger and go 12 & 1.  

A couple of things to realize.  First - what difference does it make what Coil 2 is doing if it's not even connected to anything?  Second, unless this is an engine swap into some other vehicle, AEM isn't going to provide a lot of support on this since we offered a plug and play ECU solution for 2G cars that just plugged in and worked right out of the box.  The EMS-4 has also been in legacy status for a long time and support is starting to become more limited so your best option is to use what works best/easiest which is why going with a 12 & 1 setup is a good idea.