11 posts / 0 new
Last post
tommeme1
Offline
Last seen: 1 month 2 weeks ago
Joined: 03/15/2020 - 09:42
help fixing low AFR 9.7 to target AFR 14.7

car is running rich 9.7 anyone can help me or lead me towards what to adjust to fix this problem. only at idle. 

link to readings from aem tuner

https://ibb.co/wCpVjyQ

tommeme1
Offline
Last seen: 1 month 2 weeks ago
Joined: 03/15/2020 - 09:42
anyone out there ?   

anyone out there ? 

 

tommeme1
Offline
Last seen: 1 month 2 weeks ago
Joined: 03/15/2020 - 09:42
bump 

bump 

AEM_NS
Offline
Last seen: 3 days 1 hour ago
Joined: 06/06/2014 - 09:31
What size injectors are you

What size injectors are you running and what is your max injector duty cycle at peak power and max rpm?

tommeme1
Offline
Last seen: 1 month 2 weeks ago
Joined: 03/15/2020 - 09:42
1000cc injectors 

1000cc injectors 

AEM_NS
Offline
Last seen: 3 days 1 hour ago
Joined: 06/06/2014 - 09:31
Great, you answered 1 of my 3

Great, you answered 1 of my 3 questions. Look at the data and think about what's going on a little bit. Commanded fuel pulse is 1.1 ms, battery offset is 0.9 ms and net pulse is ~2 ms. You're idling at less than 2% injector duty so what's there left to do? You're already near the absolute minimum injector pulse width possible so all you can really try doing is taking out more fuel. You can try setting your fuel map cell values in the idle range to 0 and see if the engine will run off of battery offset time only since offset is accounting for about half of the total injector pulse. You didn't provide any additional info so I have no idea what engine this is, what fuel pressure you're running, how much boost you're making, max rpm, max injector duty or a whole slew of other things that pretty much make it pretty tough for anyone to give you any kind of useful help.

tommeme1
Offline
Last seen: 1 month 2 weeks ago
Joined: 03/15/2020 - 09:42
AP1 Honda S2000 2.0

AP1 Honda S2000 2.0

15psi boost max rpm 9k

i dont kow the max injector pulse 

 

tommeme1
Offline
Last seen: 1 month 2 weeks ago
Joined: 03/15/2020 - 09:42
BUMP

BUMP anyone ? any help would be appriciated

AEM_NS
Offline
Last seen: 3 days 1 hour ago
Joined: 06/06/2014 - 09:31
I already gave you a

I already gave you a suggestion to try - did you actually try it? You haven't been able to provide max injector duty values which would help give some scale to the overall sizing of the injectors. If your max duty is low then your injectors are probably way over sized and trying to get them to idle in the sub 2 ms range could mean you're in the injector's non-linear output range.  There's nothing that can be done about this phenomena so it's important that you appropriately size your injectors to provide the necessary amount of fuel you need to support your max power with only a little additional head room above this.  This way you don't wind up running your injectors in their non-linear range at idle and having uncontrollable AFRs.

BTW what are you using for wideband O2? 

tommeme1
Offline
Last seen: 1 month 2 weeks ago
Joined: 03/15/2020 - 09:42
im sory man i have 1300cc

im sory man i have 1300cc injectors not 1000 , wideband is auto meter pro comp ulta lite guage the o2 sensor is bosh brand  

AEM_NS
Offline
Last seen: 3 days 1 hour ago
Joined: 06/06/2014 - 09:31
Are you sure your wideband is

Are you sure your wideband is configured correctly?  Gauge instructions say the AFR reading range is 10.0-17.0:1 and the analog output scaling is 0-4 volts.  Showing an AFR of 9.7:1 means the analog voltage is less than 0v which isn't possible.

https://www.autometer.com/media/manual/2650-1465.pdf