Infinity 506 can't Start K20A2 | AEM
7 posts / 0 new
Last post
kittinan thaweepun
Offline
Last seen: 2 years 7 months ago
Joined: 01/05/2018 - 10:32
Infinity 506 can't Start K20A2

I have a Honda Integra DC5 Type R.
I buy the Infinity 506 with the K20A2 Harness kit 30-3502.
I installed them and try to connect to the Infinity for start with the session K20A3.The Engine can't Start.
Help me please.

kb58
Offline
Last seen: 1 year 11 months ago
Joined: 10/29/2014 - 09:21
You have to provide more

You have to provide more information than this, preferably a log. It is highly likely that you have something connected wrong, so until AEM can answer (next Monday) I strongly suggest checking that EVERY wire goes where it's supposed to, then posting a log Sunday night for their review.

Start by confirming - with a multimeter - that the correct power wires are sequencing with ignition-on.

Confirm that all the ground wires are in fact tied to a good ground.

Next, confirm that your Infinity has the Honda K-series base tune installed!

Then, confirm that the crank and cam sensor inputs are active and going to the right wires.

After all this, record and post a log here.

 

sportbikeryder
Offline
Last seen: 1 week 6 days ago
Joined: 05/23/2014 - 05:39
You should also always check

You should also always check the ignition sync with a timing light and run the diagnostic firmware to check all injector and ignition outputs. 

AEM_SB
Offline
Last seen: 2 months 3 weeks ago
Joined: 06/07/2014 - 14:29
The advice you're already

The advice you're already been given is good. Engines only need a few things to start: air, fuel, compression, and a correctly timed spark. The ECU (and wiring harness) are directly responsible for controlling the fuel and spark, so I would check those first. 

 

If you're not already familiar with how to do a basic spark test, here's a nice quick video: https://www.youtube.com/watch?v=mUOmsGiirTU

If there is no spark, skip any other tests and use the laptop software to check that the ECU is trying to activate the ignitoin coils. The ECU will only fire the coils after it has detected the cam & crank signals are present and match the pattern it has been configured to use. Look for the channel SyncState, it should be 0 when the engine is not cranking, and 1 after the ECU has spun for a few complete revolutions.

 

Fuel is easy to check that it's present, but less easy to check if the exact amount is correct. First listen that the fuel pump is running. If you have a fuel pressure gauge, there needs to be fuel pressure when the starter is cranking the engine. If you smell fuel from the tailpipe or the spark plugs are wet with fuel then you know there is fuel pressure and the ECU is firing the fuel injectors (or at least some of them). If there is correctly timed spark but the plugs come out wet, you've probably got too much fuel and need to adjust the ECU's calibration for injectors and/or cranking fuel settings.

 

If you have fuel and have spark, but are hearing popping or banging sounds that's a good indicator that some (or all) of the coils are not firing at the correct angle. In this case, recommended procedure is disable the fuel pump, get a timing light, and use the timing light to check that the ignition timing measured with the light matches what the ECU is commanding while you crank the engine. There are configuration settings in the ECU calibration that can be adjusted to synchronize the ignition timing, but those settings should already be correct if you're using an engine that matches our base calibration.

 

 

Please do post a datalog of the engine cranking, we can have someone familiar with the Infinity ECU look through your data and advise based on what we find.

AEM_NS
Offline
Last seen: 26 min 38 sec ago
Joined: 06/06/2014 - 09:31
Common problem with the 3502

Common problem with the 3502 harness is that users overlook the perm power lead that MUST be connected in order for the Infinity to work.

Tim M
Offline
Last seen: 1 month 3 weeks ago
Joined: 06/14/2020 - 09:39
Hi Guys

Hi Guys

I have a similiar issue. I have a B16 Honda engine with an additional turbo. I switched to an AEM Infinity and have the issue that when starting the car, the idling takes quite 3-5 seconds until the engine will start.

Also yesterday, I had the issue that after fueling, I tried to start my warm engine, but it couldnt start because there was no spark at no cylinder. I checked every connection and couldnt find the issue. After the engine cooled down, I could start it again with this long idling process.

I tried logging the data in this idling process, but i always get disconnected in the AEM software when i try to start the car. I am quite the beginner with the infinity (car was programmed by a company) and iam trying to find how I can log the data in this process and how to improve the starting of the engine.

Thank you

cjsdad
Offline
Last seen: 1 week 4 days ago
Joined: 07/23/2020 - 16:54
If you are being disconnected

If you are being disconnected while starting, is it possible your ignition power lead is connected to an accessory circuit rather than ignition?  This could also explain your difficulty starting since ignition circuits have power while the key is in the start position and accessory circuits do not.  Just a thought.