No start after power cycle | AEM
2 posts / 0 new
Last post
TitaniumThirteen
Offline
Last seen: 7 months 3 weeks ago
Joined: 06/05/2014 - 00:43
No start after power cycle

I was working on E36 coupe with S52B28 engine last month. The plan was to remove original ECU and utilize a 6060 unit with custom connector to mate with stock harness. Everything was working fine except one problem. Everytime I switch the power off, the EMS doesn't seem to cycle properly. The first thing that came to mind was that there might be any devices that has constant power and kept the ECU upset. I traced the wire one by one, on both input and output, but it came to the point where even with all the wires removed and left with only 12v switched power and power ground (pin A11 and A10) the EMS still won't shut down properly. Adding relays to both wires didn't work but completely removing the EMS from the harness will :-/

 

So while I was sorting the problems out, I happend to put a test light on the switched power pin (pin A11) to see if there was any power left in the wire. The light turn on and off properly with the key as expected, but what's funny is that as long as there's a small light bulb connected on this wire, the problem is simply gone. I have experimented on this issue repeatedly for a couple hours (while also trying to tune the vehicle) and it really is the solution. Again, this is just another case of coincidence that worked. In the end I had to put the A11 wire though a relay with a small bulb attached to it and finish the job.

 

So has anyone experienced anything like this before?

AEM_NS
Offline
Last seen: 46 min 1 sec ago
Joined: 06/06/2014 - 09:31
Yes but not on a car.  It was

Yes but not on a car.  It was actually on a DTS engine dyno.  It had been working fine for a long time (forever AFAIK) and then all of a sudden ECU's started hanging on when the ignition was turned off in the control room.  Did some probing with a multimeter and discovered that the ignition switch wire to the EMS wasn't going to 0v when turned off.  Put a test light in the circuit and it worked from then on.