Rev Limiter stopped working and hard start after injector install | AEM
2 posts / 0 new
Last post
chipmonkey
Offline
Last seen: 1 year 6 months ago
Joined: 08/05/2014 - 18:01
Rev Limiter stopped working and hard start after injector install

Having a strange issue with my rev limiter.  It has been working fine for years with no issues.  I have the main limiter set on hard limit with near stock settings for the 1601 box.  I have the 2 step set and that still works.  I installed a new transmission and in the process had the battery unhooked (Which shouldn't matter to AEM) and now my main limiter is just plain not working.  I have gone through and reset all my limiter setting and used the wizard to set the hard cut and limits but the limiter just isn't there.  I can set it to 2000 RPM with everything cut and it doesn't respond at all.  The 2 step works fine so I am temporarily using that as my main limiter so I don't shuck any more rockers.  I am still running version 1.11, never had a reason to update. 

 

Another issue I have run into is starting.  I installed Precision 1000cc injectors and have had a problem getting the car to start nicely.  Originally running MSD 52lbs injectors it used to start like factory with the added AEM inital revolution (Stat sync) time.  I've rescaled everything for the Injectors but don't know if there are some tips on different settings when starting much larger injectors.  I've gone through the crank injector time table trying everything from 10 to 140 and it starts almost the same throughout.  It's acting like it's too much fuel because you can give it a little gas opening the butterfly and it will start right up. If I don't give it any gas it will kick over real quick but not start, if you keep cranking it will start well after about 5 seconds of cranking.  The stat sync and all starting parameters are met when the engine first sputters over but doesn't start so I know it's not waiting for sync or anything.  I didn't know if I would need to make major changes to the initial crank pulse table or anything else?  I have also tried different ranges in the start extra vs temp table.  If I select crank inject all it doesn't want to start very well at all which further makes me believe it's getting too much fuel.  Another factor may be my timing.  I'm running a lot of timing at idle to get my 272 intake cam to idle halfway decent.  I have tried zeroing out the timing advance for start as well with no change. 

 

Thanks for any help.

spoon_ek9
Offline
Last seen: 3 years 2 months ago
Joined: 11/23/2014 - 20:59
changing injector is not

changing injector is not "just" a rescale.  differnt injector have different setting.  

GK System - Efi and data acq specialist