track mapping | AEM
17 posts / 0 new
Last post
Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
track mapping

hi guys, his somebody have good experience with track mapping with aemdata ??

im able to configure distance channel and G channel but the best track map ive got is a circle or hexagon figure ..... still didnt have clear response concerning g channel  in the forum, im able to get the raw data in volt from my g channel but cannot make the perfect math conversion .... by exemple most popular datalogger from other brand know by default that the positive G value means left hand turn  putting force to the right side of the vehicule and negative G value for the right hand turn etc ...there is anywhere where the g analysis software is explain, how to set raw value convert into g value and same thing concerning left hand turn and right hand turn....

thx

best ragards

dave

AEM_GN
Offline
Last seen: 4 years 6 months ago
Joined: 02/18/2014 - 09:55
Are you using the AQ1 for

Are you using the AQ1 for datalogging?

Did you go into the AQ-1 software and setup the Accelerometer mounting position?

If you have than good. Now right click on the open space. Add View -> Track

Click the little wrench in the upper right hand corner. This will bring up the Track View Configuration.

Click Edit which will open the Track Editor

Yaw/G
Open Stage
Sensor G Sensor(Invert Sensor this may not have to be done)
G Channel Lateral g
Speed Channel Wheel Speed

Than just fine tune the other settings to get the track to look how you want.

Also another thing is you can go to File -> Open Log -> My Documents -> AEM -> AEMdata -> logs -> AEMdataDemo
Open that one up and the track map will already be configured and should display you can look at the settings in there to get the idea.

Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
no, im using the infinity thx

no, im using the infinity

thx

AEM_NS
Offline
Last seen: 2 hours 26 min ago
Joined: 06/06/2014 - 09:31
It seems like the problem

It seems like the problem might be a lack of appropriate data.  The AQ-1 can very easily do a g-based track map using its own internal accelerometer just like you mention the other popular logger can do.  But you're not using the AQ-1 -  you're using an external input into the Infinity and logging a raw voltage.  You say you can't make a perfect math conversion - why not?  What does the sensor manufacturer give you as a transfer function?  I think it'd be difficult for AEMData to give you a better track map if there isn't better data to base it off of.

Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
what you mean by transfer

what you mean by transfer function ?!? about the math conversion there is no where we could tell that this amount of positve G mean left hand turn and this amount og négative G mean right hand turn ?? of course its possible to convert voltage raw value to réal G value...

thx

AEM_NS
Offline
Last seen: 2 hours 26 min ago
Joined: 06/06/2014 - 09:31
In order for the track editor

In order for the track editor to give you a good track it needs to get good complete data.  In Track Editor, when you configure it to based off of G sensor, it will reference both a G and vehicle speed channel.  Both of these channels need to be properly scaled and provide data with appropriate units (Gs for the G chanel and mph/kph for speed).  Are you reference a good speed channel?  Are you referencing a good G channel?  Is your G channel input properly calibrated (this is where the transfer function to take volts and make it read G comes in) and does it scale out appropriately?  When not turning are you getting zero latitudinal Gs?  The fact that you keep getting circles or hexagons for a track map could mean that your not referencing a G channel that has both positive and negative values.  The math to translate Gs and speed to turns degrees/duration is already in the software and generally does not need direct adjusting.  The adjustments are made using the Offset and Multiplier values.  

I would say that you should double check that your G and speed channels are good and right and that if you continue to have problems, you could send us your log files and we could try doing it on our end to see if we can do it for you.

Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
Ok thank for the info , ill

Ok thank for the info , ill try to make it over the weekend and ill let you know with my update !!

 

 

Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
after many try cannot create

after many try cannot create the appropriate math conversion channel ... here my number lets see if you guys can sort it out , from my sensor the raw value in volt

is 2.5 volt for vehicule going straight, at 3,4 volt it should be 1G and 1.6 volt for -1G.  

let me know

thx 

sportbikeryder
Offline
Last seen: 1 month 3 weeks ago
Joined: 05/23/2014 - 05:39
Your sensor is based on 2.5V

Your sensor is based on 2.5V (centered between 0-5V when reading zero G's)

Sensitivity is 0.9V/G  (2.5+0.9=3.4V for 1G)

 

"G's" = (X-2.5)/0.9

X is output voltage

The 2.5 must be subtracted to offset the sensor to zero at zero G's

The 0.9 is the sensitivity to convert G to volts input

 

To get an understanding of how it works, go ahead adn plug in voltage numbers for "X" and see what the calculation comes out to.

John

AEM_NS
Offline
Last seen: 2 hours 26 min ago
Joined: 06/06/2014 - 09:31
Looks like the transfer

Looks like the transfer function is G = 1.1111*volts - 2.7778.  Is that what you've been using?  

Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
thank guys for the conversion

thank guys for the conversion maths !! finally create the conversion channel, but my mapping is still not working... now the mappping of the track is no longer

a circle but is look like a triangle ?!? any idea why ??

 

AEM_NS
Offline
Last seen: 2 hours 26 min ago
Joined: 06/06/2014 - 09:31
Please post you log so we can

Please post you log so we can try it ourselves.  Attach it as a forum file and attach into your post.

Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
https://drive.google.com/a
Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
cannot share with other

cannot share with other peaple than my company sorry ..... send by email.

 

let me know 

Davide46
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/20/2014 - 16:59
finally figure it out ! When

finally figure it out ! When you create the track mapping we need to select a part of the logging that it seem to be1 lap and select that selection instead of the entire logging, so the system can figure When this sélection is repeating it mean that another lap is started....

AEM_NS
Offline
Last seen: 2 hours 26 min ago
Joined: 06/06/2014 - 09:31
Glad you got it sorted out.

Glad you got it sorted out.  Sorry that I didn't get back to you via email.  I never had a chance to check out your log as things have been crazy busy here!  

blacksaleen95
Offline
Last seen: 1 year 3 months ago
Joined: 06/03/2014 - 19:32
No problems using AQ-1 G

No problems using AQ-1 G sensor, and both 5hz Garmin and the 10hz locosys GPS..