Topic / Topic starter Replies Last postsort ascending
Normal topic 30-6040 stock jumper positions
by Jab_eg » Tue, 06/27/2017 - 12:36
1
by AEM_NS
Tue, 06/27/2017 - 14:44
Normal topic 7MGTE CPS Sync Erros / losing Sync Tooth
by wisetechscott » Mon, 06/19/2017 - 05:38
2
by Kurt
Mon, 06/19/2017 - 11:13
Normal topic intermittent misfires, cam sensor issure?
by ba5il » Sun, 06/18/2017 - 17:11
1
by AEM_NS
Mon, 06/19/2017 - 09:18
Normal topic AEM EMS Evo III Timing Errors and RPM Issue.
by jasonharward » Mon, 06/12/2017 - 21:27
3
by AEM_NS
Thu, 06/15/2017 - 08:47
Normal topic 30-6611 First start, running too rich
by jmss123 » Sun, 06/11/2017 - 01:47
0
by jmss123
Sun, 06/11/2017 - 01:47
Normal topic MAP sensor calibration
by azfiveoh » Tue, 06/06/2017 - 10:25
4
by azfiveoh
Tue, 06/06/2017 - 13:06
Normal topic AEM on chrome
by toddrs93 » Sun, 06/04/2017 - 09:20
1
by AEM_PT
Tue, 06/06/2017 - 10:49
Normal topic 30-0310 X-Series UEGO with AEM Series 2
by boosteditr » Mon, 05/22/2017 - 03:16
2
by boosteditr
Sat, 06/03/2017 - 00:48
Normal topic Coil outputs randomly not working
by azfiveoh » Mon, 05/29/2017 - 21:05
5
by AEM_NS
Fri, 06/02/2017 - 11:59
Normal topic 30-6310 Ford PWM IAC on Injector 10
by mdanhof » Wed, 05/31/2017 - 14:19
1
by AEM_NS
Wed, 05/31/2017 - 15:43
Hot topic Timing not changing
by azfiveoh » Tue, 05/16/2017 - 14:21
15
by azfiveoh
Mon, 05/29/2017 - 19:48
Normal topic Ford IACV using LS output
by darkness » Fri, 04/28/2017 - 12:48
4
by AEM_NS
Wed, 05/24/2017 - 07:50
Normal topic aem v2 30-6310 switches not sending 12v signal to 2nd pump relay
by Boostfilmssfl » Tue, 05/16/2017 - 17:26
3
by Boostfilmssfl
Tue, 05/16/2017 - 18:09
Normal topic 30-6050 PW1 for IAC
by azfiveoh » Mon, 05/15/2017 - 14:47
2
by azfiveoh
Tue, 05/16/2017 - 14:05
Normal topic Plans to support VVTI 1JZ/2JZ engines?
by toyotanos » Thu, 06/25/2015 - 12:33
3
by Kceries
Tue, 05/02/2017 - 20:15
Normal topic Activating an actuator, HELP
by boostedj30 » Sun, 03/12/2017 - 12:32
7
by R81_UP
Sun, 04/30/2017 - 11:26
Normal topic 2jz wont rev past 2400rpm constant misfires.
by 2jzSC » Sat, 04/29/2017 - 16:19
0
by 2jzSC
Sat, 04/29/2017 - 16:20
Normal topic 7MGTE AEM EMS 2 i want to drive smoothly.
by Phoubles » Sun, 04/23/2017 - 10:03
0
by Phoubles
Sun, 04/23/2017 - 10:03
Normal topic Supra mk3 2JZGTE won't start. IAC valve issue.
by Supraclaou » Sat, 04/22/2017 - 19:36
1
by Supraclaou
Sat, 04/22/2017 - 19:38
Normal topic 30-6030 K20 ITB VVC issue - Please Help
by AreaMS » Fri, 04/21/2017 - 17:08
1
by AEM_NS
Fri, 04/21/2017 - 17:33
Normal topic Strain Gauge Shift Cut
by Chachy » Mon, 01/09/2017 - 06:11
4
by AEM_NS
Fri, 04/21/2017 - 09:31
Normal topic No start on cold start
by Boosteddsm » Wed, 04/19/2017 - 10:59
4
by Boosteddsm
Thu, 04/20/2017 - 20:15
Normal topic Locating cylinder misfire
by boostedj30 » Mon, 04/17/2017 - 05:34
1
by AEM_NS
Mon, 04/17/2017 - 09:39
Normal topic EMS 30-6060>17psi+ Boost Misfire B Series Honda>>Logs attached
by ICE Cold » Sat, 04/01/2017 - 20:33
1
by AEM_NS
Mon, 04/10/2017 - 10:51
Normal topic ems series 2 driver error
by Telos14 » Sun, 04/09/2017 - 07:40
0
by Telos14
Sun, 04/09/2017 - 07:40
New posts
No new posts
Hot topic with new posts
Hot topic without new posts
Sticky topic
Locked topic
Subscribe to RSS - AEM Series 2 Plug & Play Programmable Engine Management System